# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=\d{3}\s)([A-Za-z\.]*)\s([A-Za-z\.]*)"
test_str = ("009 G Nantpaipakdee 38 955 722 650-240-0111\n"
"002 Eugénie Romette 432 734 782\n"
"005 Christina Pandullo 410-527-8241 410-527-8158\n"
"020 Joe Smith 410-771-7815 410-527-8771\n"
"030 K Kordysiewicz 42 239 3875\n"
"300 Cecile A. Wattiez 432 736 683\n"
"305 Do not use")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.