const regex = /(?<=\d{3}\s)([A-Za-z\.]*)\s([A-Za-z\.]*)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\d{3}\\s)([A-Za-z\\.]*)\\s([A-Za-z\\.]*)', 'gm')
const str = `009 G Nantpaipakdee 38 955 722 650-240-0111
002 Eugénie Romette 432 734 782
005 Christina Pandullo 410-527-8241 410-527-8158
020 Joe Smith 410-771-7815 410-527-8771
030 K Kordysiewicz 42 239 3875
300 Cecile A. Wattiez 432 736 683
305 Do not use`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}