using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(dc|dcterms)\.title(?!\.alternative).*$";
string input = @"dc.title
dc.title[en_US]
dc.title[]
dc.title.alternative
dcterms.title
dcterms.title[en_US]
dcterms.title[]";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}