$re = '/^(dc|dcterms)\.title(?!\.alternative).*$/m';
$str = 'dc.title
dc.title[en_US]
dc.title[]
dc.title.alternative
dcterms.title
dcterms.title[en_US]
dcterms.title[]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);