re = /^(dc|dcterms)\.title(?!\.alternative).*$/m
str = 'dc.title
dc.title[en_US]
dc.title[]
dc.title.alternative
dcterms.title
dcterms.title[en_US]
dcterms.title[]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end