import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(dc|dcterms)\\.title(?!\\.alternative).*$";
final String string = "dc.title\n"
+ "dc.title[en_US]\n"
+ "dc.title[]\n"
+ "dc.title.alternative\n"
+ "dcterms.title\n"
+ "dcterms.title[en_US]\n"
+ "dcterms.title[]";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}