#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\"wallet\": \"0x5C98Dc37c0b3Ef75476EB6B8ef0d564f7c6AF6Ae\""
Local $sString = "{" & @CRLF & _
" "wallet": "0x5C98Dc37c0b3Ef75476EB6B8ef0d564f7c6AF6Ae"," & @CRLF & _
" "symbol": "EOS"," & @CRLF & _
" "balance": "0"," & @CRLF & _
" "eth_balance": "0.0269669716"," & @CRLF & _
" "decimals": 18," & @CRLF & _
" "block": 5977940" & @CRLF & _
"}"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")