re = /\"wallet\": \"0x5C98Dc37c0b3Ef75476EB6B8ef0d564f7c6AF6Ae\"/m
str = '{
"wallet": "0x5C98Dc37c0b3Ef75476EB6B8ef0d564f7c6AF6Ae",
"symbol": "EOS",
"balance": "0",
"eth_balance": "0.0269669716",
"decimals": 18,
"block": 5977940
}'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end