using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\""wallet\"": \""0x5C98Dc37c0b3Ef75476EB6B8ef0d564f7c6AF6Ae\""";
string input = @"{
""wallet"": ""0x5C98Dc37c0b3Ef75476EB6B8ef0d564f7c6AF6Ae"",
""symbol"": ""EOS"",
""balance"": ""0"",
""eth_balance"": ""0.0269669716"",
""decimals"": 18,
""block"": 5977940
}";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}