use strict;
my $str = '{
"wallet": "0x5C98Dc37c0b3Ef75476EB6B8ef0d564f7c6AF6Ae",
"symbol": "EOS",
"balance": "0",
"eth_balance": "0.0269669716",
"decimals": 18,
"block": 5977940
}';
my $regex = qr`\"wallet\": \"0x5C98Dc37c0b3Ef75476EB6B8ef0d564f7c6AF6Ae\"`mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}