package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\"wallet\": \"0x5C98Dc37c0b3Ef75476EB6B8ef0d564f7c6AF6Ae\"`)
var str = `{
"wallet": "0x5C98Dc37c0b3Ef75476EB6B8ef0d564f7c6AF6Ae",
"symbol": "EOS",
"balance": "0",
"eth_balance": "0.0269669716",
"decimals": 18,
"block": 5977940
}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}