# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\n.*\"/\"/gm;t' <<< " USA - Boston \"sa-boston-ubuntu-l2tp.xvnet.net\"
USA - Los Angeles \"a1-ubuntu-l2tp.expressprovider.com\"
USA - Atlanta \"tlanta-ubuntu-l2tp.xvnet.net\"
Canada - Montreal \"ontreal1-ubuntu-l2tp.xvnet.net
\""