re = /\n.*\"/m
str = ' USA - Boston "sa-boston-ubuntu-l2tp.xvnet.net"
USA - Los Angeles "a1-ubuntu-l2tp.expressprovider.com"
USA - Atlanta "tlanta-ubuntu-l2tp.xvnet.net"
Canada - Montreal "ontreal1-ubuntu-l2tp.xvnet.net
"'
subst = '\\"'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result