use strict;
my $str = ' USA - Boston "sa-boston-ubuntu-l2tp.xvnet.net"
USA - Los Angeles "a1-ubuntu-l2tp.expressprovider.com"
USA - Atlanta "tlanta-ubuntu-l2tp.xvnet.net"
Canada - Montreal "ontreal1-ubuntu-l2tp.xvnet.net
"';
my $regex = qr/\n.*\"/mp;
my $subst = '\\"';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";