// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\n.*\""#).unwrap();
let string = " USA - Boston \"sa-boston-ubuntu-l2tp.xvnet.net\"
USA - Los Angeles \"a1-ubuntu-l2tp.expressprovider.com\"
USA - Atlanta \"tlanta-ubuntu-l2tp.xvnet.net\"
Canada - Montreal \"ontreal1-ubuntu-l2tp.xvnet.net
\"";
let substitution = "\\\"";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}