import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:(?:\\+?234(?:\\h1)?|01)\\h*)?(?:\\(\\d{3}\\)|\\d{3})|\\d{4})(?:\\W*\\d{3})?\\W*\\d{4}$";
final String string = "9999 999 9999\n"
+ "01 999 9999\n"
+ "+234 1 999 9999\n"
+ "9999-999-9999\n"
+ "99999999999\n"
+ "234 999 999 9999\n"
+ "234(999)999-9999\n"
+ "234(999)999 9999\n"
+ "+234(999)999 9999\n"
+ "+234(999) 999 9999\n"
+ "+234(999)999-9999\n"
+ "2349999999999\n"
+ "+2349999999999\n\n"
+ "At most 11 digits long (any number combo, excluding the static parts)\n"
+ "Optional (234) or (+234)\n"
+ "Optional 1 or 01 or 234 1\n"
+ "Optional bracketing as specified above.";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}