# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?:(?:(?:\+?234(?:\h1)?|01)\h*)?(?:\(\d{3}\)|\d{3})|\d{4})(?:\W*\d{3})?\W*\d{4}$"
test_str = ("9999 999 9999\n"
"01 999 9999\n"
"+234 1 999 9999\n"
"9999-999-9999\n"
"99999999999\n"
"234 999 999 9999\n"
"234(999)999-9999\n"
"234(999)999 9999\n"
"+234(999)999 9999\n"
"+234(999) 999 9999\n"
"+234(999)999-9999\n"
"2349999999999\n"
"+2349999999999\n\n"
"At most 11 digits long (any number combo, excluding the static parts)\n"
"Optional (234) or (+234)\n"
"Optional 1 or 01 or 234 1\n"
"Optional bracketing as specified above.")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.