use strict;
my $str = '9999 999 9999
01 999 9999
+234 1 999 9999
9999-999-9999
99999999999
234 999 999 9999
234(999)999-9999
234(999)999 9999
+234(999)999 9999
+234(999) 999 9999
+234(999)999-9999
2349999999999
+2349999999999
At most 11 digits long (any number combo, excluding the static parts)
Optional (234) or (+234)
Optional 1 or 01 or 234 1
Optional bracketing as specified above.';
my $regex = qr/^(?:(?:(?:\+?234(?:\h1)?|01)\h*)?(?:\(\d{3}\)|\d{3})|\d{4})(?:\W*\d{3})?\W*\d{4}$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}