re = /^(?:(?:(?:\+?234(?:\h1)?|01)\h*)?(?:\(\d{3}\)|\d{3})|\d{4})(?:\W*\d{3})?\W*\d{4}$/m
str = '9999 999 9999
01 999 9999
+234 1 999 9999
9999-999-9999
99999999999
234 999 999 9999
234(999)999-9999
234(999)999 9999
+234(999)999 9999
+234(999) 999 9999
+234(999)999-9999
2349999999999
+2349999999999
At most 11 digits long (any number combo, excluding the static parts)
Optional (234) or (+234)
Optional 1 or 01 or 234 1
Optional bracketing as specified above.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end