import Foundation
let pattern = #"^(?:(?:(?:\+?234(?:\h1)?|01)\h*)?(?:\(\d{3}\)|\d{3})|\d{4})(?:\W*\d{3})?\W*\d{4}$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
9999 999 9999
01 999 9999
+234 1 999 9999
9999-999-9999
99999999999
234 999 999 9999
234(999)999-9999
234(999)999 9999
+234(999)999 9999
+234(999) 999 9999
+234(999)999-9999
2349999999999
+2349999999999
At most 11 digits long (any number combo, excluding the static parts)
Optional (234) or (+234)
Optional 1 or 01 or 234 1
Optional bracketing as specified above.
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)