const regex = /^(?:(?:(?:\+?234(?:\h1)?|01)\h*)?(?:\(\d{3}\)|\d{3})|\d{4})(?:\W*\d{3})?\W*\d{4}$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?:(?:\\+?234(?:\\h1)?|01)\\h*)?(?:\\(\\d{3}\\)|\\d{3})|\\d{4})(?:\\W*\\d{3})?\\W*\\d{4}$', 'gm')
const str = `9999 999 9999
01 999 9999
+234 1 999 9999
9999-999-9999
99999999999
234 999 999 9999
234(999)999-9999
234(999)999 9999
+234(999)999 9999
+234(999) 999 9999
+234(999)999-9999
2349999999999
+2349999999999
At most 11 digits long (any number combo, excluding the static parts)
Optional (234) or (+234)
Optional 1 or 01 or 234 1
Optional bracketing as specified above.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}