#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:ABC_|CDE_|^)+(\S*?)(?:_DEF|$)"
Local $sString = "ABC_ANY_STRING_DEF" & @CRLF & _
"ANY_STRING" & @CRLF & _
"ANY_STRING_DEF" & @CRLF & _
"ABC_CDE_ANY_STRING_DEF"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")