re = /(?:ABC_|CDE_|^)+(\S*?)(?:_DEF|$)/m
str = 'ABC_ANY_STRING_DEF
ANY_STRING
ANY_STRING_DEF
ABC_CDE_ANY_STRING_DEF'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end