import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:ABC_|CDE_|^)+(\\S*?)(?:_DEF|$)";
final String string = "ABC_ANY_STRING_DEF\n"
+ "ANY_STRING\n"
+ "ANY_STRING_DEF\n"
+ "ABC_CDE_ANY_STRING_DEF";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}