$re = '/(?:ABC_|CDE_|^)+(\S*?)(?:_DEF|$)/m';
$str = 'ABC_ANY_STRING_DEF
ANY_STRING
ANY_STRING_DEF
ABC_CDE_ANY_STRING_DEF';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);