package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:ABC_|CDE_|^)+(\S*?)(?:_DEF|$)`)
var str = `ABC_ANY_STRING_DEF
ANY_STRING
ANY_STRING_DEF
ABC_CDE_ANY_STRING_DEF`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}