using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+)";
string input = @"https://www.pinterest.com/pin/29695678788111907/
https://www.pinterest.com/pin/454652524912163734/
https://www.pinterest.com/pin/192880796536873764/
https://www.pinterest.com/pin/31243791160473890/
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}