import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\d+)";
final String string = "https://www.pinterest.com/pin/29695678788111907/\n"
+ "https://www.pinterest.com/pin/454652524912163734/\n"
+ "https://www.pinterest.com/pin/192880796536873764/\n"
+ "https://www.pinterest.com/pin/31243791160473890/\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}