re = /(\d+)/m
str = 'https://www.pinterest.com/pin/29695678788111907/
https://www.pinterest.com/pin/454652524912163734/
https://www.pinterest.com/pin/192880796536873764/
https://www.pinterest.com/pin/31243791160473890/
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end