$re = '/(\d+)/m';
$str = 'https://www.pinterest.com/pin/29695678788111907/
https://www.pinterest.com/pin/454652524912163734/
https://www.pinterest.com/pin/192880796536873764/
https://www.pinterest.com/pin/31243791160473890/
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);