import re
regex = re.compile(r"(\d+)", flags=re.MULTILINE)
test_str = ("https://www.pinterest.com/pin/29695678788111907/\n"
"https://www.pinterest.com/pin/454652524912163734/\n"
"https://www.pinterest.com/pin/192880796536873764/\n"
"https://www.pinterest.com/pin/31243791160473890/\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")