// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\d+)").unwrap();
let string = "https://www.pinterest.com/pin/29695678788111907/
https://www.pinterest.com/pin/454652524912163734/
https://www.pinterest.com/pin/192880796536873764/
https://www.pinterest.com/pin/31243791160473890/
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}