#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^((?&byte))\.((?&byte))\.((?&byte))\.((?&byte))$(?(DEFINE)(?<byte>25[0-5]|2[0-4]\d|[01]?\d\d?))"
Local $sString = "128.0.25.120" & @CRLF & _
"255.255.255.255" & @CRLF & _
"0.0.0.0" & @CRLF & _
"102.10.0i.10"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")