const regex = /^((?&byte))\.((?&byte))\.((?&byte))\.((?&byte))$(?(DEFINE)(?<byte>25[0-5]|2[0-4]\d|[01]?\d\d?))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^((?&byte))\\.((?&byte))\\.((?&byte))\\.((?&byte))$(?(DEFINE)(?<byte>25[0-5]|2[0-4]\\d|[01]?\\d\\d?))', 'gm')
const str = `128.0.25.120
255.255.255.255
0.0.0.0
102.10.0i.10`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}