re = /^((?&byte))\.((?&byte))\.((?&byte))\.((?&byte))$(?(DEFINE)(?<byte>25[0-5]|2[0-4]\d|[01]?\d\d?))/m
str = '128.0.25.120
255.255.255.255
0.0.0.0
102.10.0i.10'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end