use strict;
my $str = '128.0.25.120
255.255.255.255
0.0.0.0
102.10.0i.10';
my $regex = qr/^((?&byte))\.((?&byte))\.((?&byte))\.((?&byte))$(?(DEFINE)(?<byte>25[0-5]|2[0-4]\d|[01]?\d\d?))/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}