import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^((?&byte))\\.((?&byte))\\.((?&byte))\\.((?&byte))$(?(DEFINE)(?<byte>25[0-5]|2[0-4]\\d|[01]?\\d\\d?))";
final String string = "128.0.25.120\n"
+ "255.255.255.255\n"
+ "0.0.0.0\n"
+ "102.10.0i.10";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}