using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^((?&byte))\.((?&byte))\.((?&byte))\.((?&byte))$(?(DEFINE)(?<byte>25[0-5]|2[0-4]\d|[01]?\d\d?))";
string input = @"128.0.25.120
255.255.255.255
0.0.0.0
102.10.0i.10";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}