import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<![\\w/])/?r/[\\dA-Za-z]\\w{1,20}/?(?![\\w/+])";
final String string = "Probando a detectar nombres de subreddits como\n"
+ "r/shortcuts y /r/3Dprinting, con barras delante\n"
+ "y detrás opcionales, como r/Marvel/ o /r/MCU/\n\n"
+ "Pero no debería capturar nada en:\n"
+ "- reddit.com/user/atnbueno\n"
+ "- reddit.com/r/Applesilicon/\n"
+ "- congreso.gob.ar/materialdeConsulta.php\n"
+ "- /r/SpainPolitics+AskSpain+Spain/ (feed personalizado, no subreddit)\n"
+ "- /usr/local/r/412/R.framework/Resources (ruta en un disco duro)\n\n"
+ "Además los nombres tienen un par de restricciones:\n"
+ "- r/nombre_demasiado_largo (no pueden ser de más de 21 caracteres)\n"
+ "- r/_nombre_no_valido (no pueden empezar por “_”)";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}