import re
regex = re.compile(r"(?<![\w/])/?r/[\dA-Za-z]\w{1,20}/?(?![\w/+])")
test_str = ("Probando a detectar nombres de subreddits como\n"
"r/shortcuts y /r/3Dprinting, con barras delante\n"
"y detrás opcionales, como r/Marvel/ o /r/MCU/\n\n"
"Pero no debería capturar nada en:\n"
"- reddit.com/user/atnbueno\n"
"- reddit.com/r/Applesilicon/\n"
"- congreso.gob.ar/materialdeConsulta.php\n"
"- /r/SpainPolitics+AskSpain+Spain/ (feed personalizado, no subreddit)\n"
"- /usr/local/r/412/R.framework/Resources (ruta en un disco duro)\n\n"
"Además los nombres tienen un par de restricciones:\n"
"- r/nombre_demasiado_largo (no pueden ser de más de 21 caracteres)\n"
"- r/_nombre_no_valido (no pueden empezar por “_”)")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")