use strict;
my $str = 'Probando a detectar nombres de subreddits como
r/shortcuts y /r/3Dprinting, con barras delante
y detrás opcionales, como r/Marvel/ o /r/MCU/
Pero no debería capturar nada en:
- reddit.com/user/atnbueno
- reddit.com/r/Applesilicon/
- congreso.gob.ar/materialdeConsulta.php
- /r/SpainPolitics+AskSpain+Spain/ (feed personalizado, no subreddit)
- /usr/local/r/412/R.framework/Resources (ruta en un disco duro)
Además los nombres tienen un par de restricciones:
- r/nombre_demasiado_largo (no pueden ser de más de 21 caracteres)
- r/_nombre_no_valido (no pueden empezar por “_”)';
my $regex = qr/(?<![\w/])/?r/[\dA-Za-z]\w{1,20}/?(?![\w/+])/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}