#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\bMSG.*|[SF]\d+"
Local $sString = "hi there is a multiple name:" & @CRLF & _
"S5000" & @CRLF & _
"F8000 AND THE REST OF" & @CRLF & _
"IN THE REST OF MACHINE TOOL THERE IS " & @CRLF & _
"A MSG("UTILIZZARE QUESTO MESSAGGIO DA ESTRARRE")" & @CRLF & _
"I TRY TO CHOOSE" & @CRLF & _
"S9000 F5000""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")