using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\bMSG.*|[SF]\d+";
string input = @"hi there is a multiple name:
S5000
F8000 AND THE REST OF
IN THE REST OF MACHINE TOOL THERE IS
A MSG(""UTILIZZARE QUESTO MESSAGGIO DA ESTRARRE"")
I TRY TO CHOOSE
S9000 F5000""";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}