package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\bMSG.*|[SF]\d+`)
var str = `hi there is a multiple name:
S5000
F8000 AND THE REST OF
IN THE REST OF MACHINE TOOL THERE IS
A MSG("UTILIZZARE QUESTO MESSAGGIO DA ESTRARRE")
I TRY TO CHOOSE
S9000 F5000"`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}