re = /\bMSG.*|[SF]\d+/m
str = 'hi there is a multiple name:
S5000
F8000 AND THE REST OF
IN THE REST OF MACHINE TOOL THERE IS
A MSG("UTILIZZARE QUESTO MESSAGGIO DA ESTRARRE")
I TRY TO CHOOSE
S9000 F5000"'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end