import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\bMSG.*|[SF]\\d+";
final String string = "hi there is a multiple name:\n"
+ "S5000\n"
+ "F8000 AND THE REST OF\n"
+ "IN THE REST OF MACHINE TOOL THERE IS \n"
+ "A MSG(\"UTILIZZARE QUESTO MESSAGGIO DA ESTRARRE\")\n"
+ "I TRY TO CHOOSE\n"
+ "S9000 F5000\"";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}