import Foundation
let pattern = #"\bMSG.*|[SF]\d+"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
hi there is a multiple name:
S5000
F8000 AND THE REST OF
IN THE REST OF MACHINE TOOL THERE IS
A MSG("UTILIZZARE QUESTO MESSAGGIO DA ESTRARRE")
I TRY TO CHOOSE
S9000 F5000"
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)