using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"RestApiUsernameToken Username=""([^""@]+)"", Domain=""([^""@]+){0,1}"", Digest=""([^""]+)"", Nonce=""([^""]+)"", Created=""(\d{4}-\d{2}-\d{2}T\d{2}:\d{2}:\d{2}Z)""";
string input = @"RestApiUsernameToken Username=""admin"", Domain=""default"", Digest=""+PJg7Tb3v98XnL6iJVv+v5hwhYjdzQ2tIWxvJB2cE40="", Nonce=""bfb79078ff44c35714af28b7412a702b"", Created=""2016-04-29T15:48:26Z""";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}