import re
regex = re.compile(r"RestApiUsernameToken Username=\"([^\"@]+)\", Domain=\"([^\"@]+){0,1}\", Digest=\"([^\"]+)\", Nonce=\"([^\"]+)\", Created=\"(\d{4}-\d{2}-\d{2}T\d{2}:\d{2}:\d{2}Z)\"")
test_str = "RestApiUsernameToken Username=\"admin\", Domain=\"default\", Digest=\"+PJg7Tb3v98XnL6iJVv+v5hwhYjdzQ2tIWxvJB2cE40=\", Nonce=\"bfb79078ff44c35714af28b7412a702b\", Created=\"2016-04-29T15:48:26Z\""
match = regex.search(test_str)
if match:
print(f"Match was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")