const regex = /RestApiUsernameToken Username="([^"@]+)", Domain="([^"@]+){0,1}", Digest="([^"]+)", Nonce="([^"]+)", Created="(\d{4}-\d{2}-\d{2}T\d{2}:\d{2}:\d{2}Z)"/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('RestApiUsernameToken Username="([^"@]+)", Domain="([^"@]+){0,1}", Digest="([^"]+)", Nonce="([^"]+)", Created="(\\d{4}-\\d{2}-\\d{2}T\\d{2}:\\d{2}:\\d{2}Z)"', '')
const str = `RestApiUsernameToken Username="admin", Domain="default", Digest="+PJg7Tb3v98XnL6iJVv+v5hwhYjdzQ2tIWxvJB2cE40=", Nonce="bfb79078ff44c35714af28b7412a702b", Created="2016-04-29T15:48:26Z"`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}